Vault Operators in Root Namespace May Elevate Their Privileges
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-266.
Summary
A privileged Vault operator with write permissions to the root namespace’s identity endpoint could escalate their own or another user’s privileges to Vault’s root policy. Fixed in Vault Community Edition 1.18.0 and Vault Enterprise 1.18.0, 1.17.7, 1.16.11, and 1.15.16.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HashiCorp | Vault | 0.10.4 to before 1.18.0 | 1.18.0 | Patch available | CNA |
| HashiCorp | Vault Enterprise | 0.10.4 to before 1.18.0 | 1.18.0 | Patch available | CNA |
| — | github.com/hashicorp/vault (Go) | before 1.18.0 | 1.18.0 | Patch available | GHSA-rr8j-7w34-xp5j |
| — | github.com/openbao/openbao (Go) | before 2.0.3 | 2.0.3 | Patch available | GHSA-rr8j-7w34-xp5j |
- Vault VendorHashiCorp Affected 0.10.4 to before 1.18.0 Fixed in 1.18.0 Patch available CNA
- Vault Enterprise VendorHashiCorp Affected 0.10.4 to before 1.18.0 Fixed in 1.18.0 Patch available CNA
- github.com/hashicorp/vault (Go) Vendor— Affected before 1.18.0 Fixed in 1.18.0 Patch available GHSA-rr8j-7w34-xp5j
- github.com/openbao/openbao (Go) Vendor— Affected before 2.0.3 Fixed in 2.0.3 Patch available GHSA-rr8j-7w34-xp5j
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openbao:openbao:*:*:*:*:*:*:*:* | before 2.0.3 | Vulnerable | openbao |
| cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* | 1.7.7 – 1.17.7 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* | 1.7.7 to before 1.18.0 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* | 1.15.0 to before 1.15.16; 1.16.0 to before 1.16.11 | Vulnerable | HashiCorp |
- cpe:2.3:a:openbao:openbao:*:*:*:*:*:*:*:* Versions before 2.0.3 Vulnerable ·openbao
- cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* Versions 1.7.7 – 1.17.7 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* Versions 1.7.7 to before 1.18.0 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* Versions 1.15.0 to before 1.15.16; 1.16.0 to before 1.16.11 Vulnerable ·HashiCorp
Remediation
- Fix · CNA Vault (HashiCorp) Fixed in 1.18.0
- Fix · CNA Vault Enterprise (HashiCorp) Fixed in 1.18.0
- Fix · GHSA-rr8j-7w34-xp5j github.com/hashicorp/vault (Go) Fixed in 1.18.0 Advisory →
- Fix · GHSA-rr8j-7w34-xp5j github.com/openbao/openbao (Go) Fixed in 2.0.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Openshift Container Storage 4 | Affected | No fix yet |
Not affected: 1 product
- Red Hat Openshift Data Foundation 4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9180
- 2026-10-03 Alias added: GHSA-rr8j-7w34-xp5j
References
More HashiCorp Vault vulnerabilities
- TI-2024-01904 Vault Cert Auth Method Did Not Correctly Validate Non-CA Certificates CVSS 3.1CRITICAL 9.8
- TI-2022-19053 An issue was discovered in HashiCorp Vault and Vault Enterprise before 1.11.3. CVSS 3.1CRITICAL 9.1
- TI-2020-17874 The official vault docker images before 0.11.6 contain a blank password for a root user. CVSS 3.1CRITICAL 9.8
- TI-2020-10142 HashiCorp Vault and Vault Enterprise 1.4.0 and 1.4.1, when configured with the GCP… CVSS 3.1CRITICAL 9.8
- TI-2026-04407 Vault Vulnerable to Server-Side Request Forgery in ACME Challenge Validation via Attacker-Controlled DNS CVSS 3.1HIGH 8.6
- TI-2025-05421 Arbitrary Remote Code Execution via Plugin Catalog Abuse CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-9180 · CVE Program
- CVE-2024-9180 · NVD
- FIRST EPSS
- GHSA-rr8j-7w34-xp5j · GitHub Advisory Database · CC BY 4.0
- CVE-2024-9180 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences