Read the docs
TI-2024-08521 Aliases CVE-2024-9182GHSA-x579-fc2r-gxmj

Maspik - Advanced Spam protection < 2.1.3 - Admin+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Maspik WordPress plugin before 2.1.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Maspik (Unknown): 2.1.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownMaspikbefore 2.1.32.1.3Patch availableCNA
  • Maspik VendorUnknown Affected before 2.1.3 Fixed in 2.1.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpmaspik:maspik:*:*:*:*:*:wordpress:*:*before 2.1.3Vulnerableyonifre
  • cpe:2.3:a:wpmaspik:maspik:*:*:*:*:*:wordpress:*:* Versions before 2.1.3 Vulnerable ·yonifre

Remediation

  • Fix · CNA Maspik (Unknown) Fixed in 2.1.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-9182
  2. 2026-10-03 Alias added: GHSA-x579-fc2r-gxmj

References

  • TI-2023-09795 WordPress Maspik – Spam blacklist Plugin <= 0.7.8 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-26135 WordPress Maspik – Spam blacklist Plugin <= 0.9.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2024-16558 WordPress Maspik – Spam blacklist Plugin <= 0.10.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources