BuddyPress Docs <= 2.2.3 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The BuddyPress Docs plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.2.3. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| boonebgorges | BuddyPress Docs | up to 2.2.3 | — | No fix listed | CNA |
- BuddyPress Docs Vendorboonebgorges Affected up to 2.2.3 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9207
- 2026-10-03 Alias added: GHSA-rpm2-gj54-rqvf
References
Other 5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b2181c89-4f40-45b9-8c12-448ca263a2f2?source=cve
- https://plugins.trac.wordpress.org/browser/buddypress-docs/tags/2.2.3/includes/templatetags.php#L282
- https://plugins.trac.wordpress.org/browser/buddypress-docs/tags/2.2.3/includes/addon-history.php#L368
- https://plugins.trac.wordpress.org/changeset/3162780/#file4
- https://plugins.trac.wordpress.org/changeset/3162780/#file32
More boonebgorges vulnerabilities
- TI-2025-04966 BuddyPress Docs < 2.2.5 - Subscriber+ Arbitrary Document Read/Update CVSS 3.1MEDIUM 4.3
- TI-2026-04490 BuddyPress Groupblog <= 1.9.3 - Authenticated (Subscriber+) Privilege Escalation to Administrator via Group Blog IDOR CVSS 3.1HIGH 8.8
Sources
- CVE-2024-9207 · CVE Program
- CVE-2024-9207 · NVD
- FIRST EPSS
- GHSA-rpm2-gj54-rqvf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences