Improper authentication in Canonical Authd
Priority LOW 39CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user managed by the same broker and perform any PAM operation with it, including authenticating as them.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00581 48th percentileScored 2026-11-07
Fix Fixed Authd (Canonical Ltd.): 0.3.5github.com/ubuntu/authd (Go): 0.0.0-20240930103526-63e527496b01, 0.3.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | Authd | before 0.3.5 | 0.3.5 | Patch available | CNA |
| — | github.com/ubuntu/authd (Go) | before 0.0.0-20240930103526-63e527496b01 | 0.0.0-20240930103526-63e527496b01 | Patch available | GHSA-x5q3-c8rm-w787 |
| — | github.com/ubuntu/authd (Go) | 0.1.0 to before 0.3.5 | 0.3.5 | Patch available | GHSA-x5q3-c8rm-w787 |
- Authd VendorCanonical Affected before 0.3.5 Fixed in 0.3.5 Patch available CNA
- github.com/ubuntu/authd (Go) Vendor— Affected before 0.0.0-20240930103526-63e527496b01 Fixed in 0.0.0-20240930103526-63e527496b01 Patch available GHSA-x5q3-c8rm-w787
- github.com/ubuntu/authd (Go) Vendor— Affected 0.1.0 to before 0.3.5 Fixed in 0.3.5 Patch available GHSA-x5q3-c8rm-w787
Remediation
- Fix · CNA Authd (Canonical Ltd.) Fixed in 0.3.5
- Fix · GHSA-x5q3-c8rm-w787 github.com/ubuntu/authd (Go) Fixed in 0.0.0-20240930103526-63e527496b01 Advisory →
- Fix · GHSA-x5q3-c8rm-w787 github.com/ubuntu/authd (Go) Fixed in 0.3.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9313
- 2026-10-03 Alias added: GHSA-x5q3-c8rm-w787
References
Advisory 3
More Canonical Authd vulnerabilities
- TI-2025-05129 Improper Permission Management in SSH Session Handling CVSS 3.1HIGH 8.5
- TI-2024-08644 Authd, through version 0.3.6, did not sufficiently randomize user IDs to prevent… CVSS 3.1HIGH 7.5
Sources
- CVE-2024-9313 · CVE Program
- CVE-2024-9313 · NVD
- FIRST EPSS
- GHSA-x5q3-c8rm-w787 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences