Slim Select 2.0 createOption "text" XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Slim Select 2.0 versions through 2.9.0 are affected by a potential cross-site scripting vulnerability. In select.ts:createOption(), the text variable from the user-provided Options object is assigned to an innerHTML without sanitation. Software that depends on this library to dynamically generate lists using unsanitized user-provided input may be vulnerable to cross-site scripting, resulting in attacker executed JavaScript. At this time, no patch is available.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | slim-select | 2.0 – 2.9.0 | — | No fix listed | CNA |
| — | slim-select (npm) | 2.0.0 to before 2.9.2 | 2.9.2 | Patch available | GHSA-qvqv-mcxr-x8qw |
- slim-select Vendor— Affected 2.0 – 2.9.0 Fixed in — No fix listed CNA
- slim-select (npm) Vendor— Affected 2.0.0 to before 2.9.2 Fixed in 2.9.2 Patch available GHSA-qvqv-mcxr-x8qw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:slimselectjs:slim_select:*:*:*:*:*:node.js:*:* | before 2.9.2 | Vulnerable | Slimselectjs |
- cpe:2.3:a:slimselectjs:slim_select:*:*:*:*:*:node.js:*:* Versions before 2.9.2 Vulnerable ·Slimselectjs
Remediation
- Fix · GHSA-qvqv-mcxr-x8qw slim-select (npm) Fixed in 2.9.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9440
- 2026-10-03 Alias added: GHSA-qvqv-mcxr-x8qw
References
Sources
- CVE-2024-9440 · CVE Program
- CVE-2024-9440 · NVD
- FIRST EPSS
- GHSA-qvqv-mcxr-x8qw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences