PAN-OS: Privilege Escalation (PE) Vulnerability in XML API
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
A privilege escalation (PE) vulnerability in the XML API of Palo Alto Networks PAN-OS software enables an authenticated PAN-OS administrator with restricted privileges to use a compromised XML API key to perform actions as a higher privileged PAN-OS administrator. For example, an administrator with "Virtual system administrator (read-only)" access could use an XML API key of a "Virtual system administrator" to perform write operations on the virtual system configuration even though they should be limited to read-only operations.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | PAN-OS | 11.0.0 to before 11.0.3; 10.1.0 to before 10.1.11; 10.2.0 to before 10.2.8; 9.1; 9.0 | 11.1.0, 11.0.3, 10.1.11, 10.2.8 | Patch available | CNA |
| Palo Alto Networks | Cloud NGFW | — | All | Patch available | CNA |
| Palo Alto Networks | Prisma Access | — | All | Patch available | CNA |
- PAN-OS VendorPalo Alto Networks Affected 11.0.0 to before 11.0.3; 10.1.0 to before 10.1.11; 10.2.0 to before 10.2.8; 9.1; 9.0 Fixed in 11.1.0, 11.0.3, 10.1.11, 10.2.8 Patch available CNA
- Cloud NGFW VendorPalo Alto Networks Affected — Fixed in All Patch available CNA
- Prisma Access VendorPalo Alto Networks Affected — Fixed in All Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | 9.0.0 to before 10.0.0; 10.1.0 to before 10.1.11; 10.2.0 to before 10.2.8; 11.0.0 to before 11.0.3 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions 9.0.0 to before 10.0.0; 10.1.0 to before 10.1.11; 10.2.0 to before 10.2.8; 11.0.0 to before 11.0.3 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 11.1.0, 11.0.3, 10.1.11, 10.2.8
- Fix · CNA Cloud NGFW (Palo Alto Networks) Fixed in All
- Fix · CNA Prisma Access (Palo Alto Networks) Fixed in All
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9471
- 2026-10-03 Alias added: GHSA-p24w-fv79-9hfm
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2024-9471 · CVE Program
- CVE-2024-9471 · NVD
- FIRST EPSS
- GHSA-p24w-fv79-9hfm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences