Inclusion of Sensitive Information in Source Code in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
An issue has been discovered in GitLab EE affecting all versions starting from 16.6 prior to 17.2.9, from 17.3 prior to 17.3.5, and from 17.4 prior to 17.4.2. It was possible for an unauthenticated attacker to determine the GitLab version number for a GitLab instance.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 16.6 to before 17.2.9; 17.3 to before 17.3.5; 17.4 to before 17.4.2 | 17.2.9, 17.3.5, 17.4.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 16.6 to before 17.2.9; 17.3 to before 17.3.5; 17.4 to before 17.4.2 Fixed in 17.2.9, 17.3.5, 17.4.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.6.0 to before 17.2.9; 17.3.0 to before 17.3.5; 17.4.0 to before 17.4.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.6.0 to before 17.2.9; 17.3.0 to before 17.3.5; 17.4.0 to before 17.4.2 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 17.2.9, 17.3.5, 17.4.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 17.2.9, 17.3.5, 17.4.2
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2024-08335 Server-Side Request Forgery (SSRF) in GitLabPriority LOW 38
- TI-2024-06056 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLabPriority LOW 38
- TI-2024-08928 Incorrect Authorization in GitLabPriority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9596
- 2026-10-03 Alias added: GHSA-r4v6-vp2q-qh25
References
Other 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-9596 · CVE Program
- CVE-2024-9596 · NVD
- FIRST EPSS
- GHSA-r4v6-vp2q-qh25 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences