Read the docs
TI-2024-09130 Aliases CVE-2024-9838GHSA-28cc-3w24-mfvx

Auto Affiliate Links < 6.4.7 - Admin+ SQL Injection

Priority MEDIUM 60CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.

Summary

The Auto Affiliate Links WordPress plugin before 6.4.7 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0034 27th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Auto Affiliate Links (Unknown): 6.4.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAuto Affiliate Linksbefore 6.4.76.4.7Patch availableCNA
  • Auto Affiliate Links VendorUnknown Affected before 6.4.7 Fixed in 6.4.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flamescorpion:auto_affiliate_links:*:*:*:*:*:wordpress:*:*before 6.4.7VulnerableLucian Apostol
  • cpe:2.3:a:flamescorpion:auto_affiliate_links:*:*:*:*:*:wordpress:*:* Versions before 6.4.7 Vulnerable ·Lucian Apostol

Remediation

  • Fix · CNA Auto Affiliate Links (Unknown) Fixed in 6.4.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-9838
  2. 2026-10-03 Alias added: GHSA-28cc-3w24-mfvx

References

  • TI-2023-11218 WordPress Auto Affiliate Links Plugin <= 6.3.0.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-08864 WordPress Auto Affiliate Links Plugin <= 6.3 is vulnerable to Broken Access Control CVSS 3.1HIGH 8.8
  • TI-2023-25792 WordPress Auto Affiliate Links Plugin <= 6.4.2.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 7.1
  • TI-2024-01715 Auto Affiliate Links <= 6.4.3 - Missing Authorization via aalAddLink CVSS 3.1MEDIUM 4.3

Sources