Read the docs
TI-2024-09360 Aliases CVE-2024-10098GHSA-h58h-p5x5-v3wj

ApplyOnline – Application Form Builder and Manager < 2.6.3 - Unauthenticated Application File Access

Priority MEDIUM 47Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The ApplyOnline WordPress plugin before 2.6.3 does not protect uploaded files during the application process, allowing unauthenticated users to access them and any private information they contain

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00419 36th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed ApplyOnline (Unknown): 2.6.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownApplyOnlinebefore 2.6.32.6.3Patch availableCNA
  • ApplyOnline VendorUnknown Affected before 2.6.3 Fixed in 2.6.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:spiderteams:applyonline_-_application_form_builder_and_manager:*:*:*:*:*:wordpress:*:*before 2.6.3VulnerableSpider Teams
  • cpe:2.3:a:spiderteams:applyonline_-_application_form_builder_and_manager:*:*:*:*:*:wordpress:*:* Versions before 2.6.3 Vulnerable ·Spider Teams

Remediation

  • Fix · CNA ApplyOnline (Unknown) Fixed in 2.6.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-10098
  2. 2026-10-03 Alias added: GHSA-h58h-p5x5-v3wj

References

  • TI-2023-24530 WordPress ApplyOnline – Application Form Builder and Manager Plugin <= 2.5.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2023-10013 WordPress ApplyOnline – Application Form Builder and Manager Plugin <= 2.5 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources