NGINX OpenID Connect Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-384.
Summary
A session fixation issue was discovered in the NGINX OpenID Connect reference implementation, where a nonce was not checked at login time. This flaw allows an attacker to fix a victim's session to an attacker-controlled account. As a result, although the attacker cannot log in as the victim, they can force the session to associate it with the attacker-controlled account, leading to potential misuse of the victim's session.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| F5 | NGINX Instance Manager | 2.5.0 to before 2.17.4 | 2.17.4 | Patch available | CNA |
| F5 | NGINX API Connectivity Manager | 1.0.0 to before 1.9.3 | 1.9.3 | Patch available | CNA |
| F5 | NGINX Ingress Controller | 1.0.0 to before 3.7.1 | 3.7.1 | Patch available | CNA |
- NGINX Instance Manager VendorF5 Affected 2.5.0 to before 2.17.4 Fixed in 2.17.4 Patch available CNA
- NGINX API Connectivity Manager VendorF5 Affected 1.0.0 to before 1.9.3 Fixed in 1.9.3 Patch available CNA
- NGINX Ingress Controller VendorF5 Affected 1.0.0 to before 3.7.1 Fixed in 3.7.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:f5:nginx_api_connectivity_manager:*:*:*:*:*:*:*:* | 1.3.0 to before 1.9.3 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:*:*:*:* | up to 1.12.5; 2.2.1 – 2.4.2; 3.0.0 to before 3.7.1 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* | 2.5.0 to before 2.17.4 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_openid_connect:*:*:*:*:*:nginx_plus:*:* | before 2024-10-24 | Vulnerable | F5 |
- cpe:2.3:a:f5:nginx_api_connectivity_manager:*:*:*:*:*:*:*:* Versions 1.3.0 to before 1.9.3 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:*:*:*:* Versions up to 1.12.5; 2.2.1 – 2.4.2; 3.0.0 to before 3.7.1 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* Versions 2.5.0 to before 2.17.4 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_openid_connect:*:*:*:*:*:nginx_plus:*:* Versions before 2024-10-24 Vulnerable ·F5
Remediation
- Fix · CNA NGINX Instance Manager (F5) Fixed in 2.17.4
- Fix · CNA NGINX API Connectivity Manager (F5) Fixed in 1.9.3
- Fix · CNA NGINX Ingress Controller (F5) Fixed in 3.7.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Trusted Artifact Signer
- Red Hat Trusted Profile Analyzer
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10318
- 2026-10-03 Alias added: GHSA-8mqv-23wv-wqfg
References
More F5 Nginx Api Connectivity Manager vulnerabilities
- TI-2023-13174 NGINX Management Suite vulnerability CVSS 3.1HIGH 8.1
- TI-2023-13238 NGINX Management Suite vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2024-10318 · CVE Program
- CVE-2024-10318 · NVD
- FIRST EPSS
- GHSA-8mqv-23wv-wqfg · GitHub Advisory Database · CC BY 4.0
- CVE-2024-10318 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences