Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab VSCode Fork
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
An issue has been discovered in the gitlab-web-ide-vscode-fork component distributed over CDN affecting all versions prior to 1.89.1-1.0.0-dev-20241118094343and used by all versions of GitLab CE/EE starting from 15.11 prior to 17.3 and which also temporarily affected versions 17.4, 17.5 and 17.6, where a XSS attack was possible when loading .ipynb files in the web IDE
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab VSCode Fork | before 1.89.1-1.0.0-dev-20241118094343 | 1.89.1-1.0.0-dev-20241118094343 | Patch available | CNA |
- GitLab VSCode Fork VendorGitLab Affected before 1.89.1-1.0.0-dev-20241118094343 Fixed in 1.89.1-1.0.0-dev-20241118094343 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.11.0 to before 17.3.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.11.0 to before 17.3.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.4.0:*:*:*:community:*:*:* | 17.4.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.4.0:*:*:*:enterprise:*:*:* | 17.4.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.5.0:*:*:*:community:*:*:* | 17.5.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.5.0:*:*:*:enterprise:*:*:* | 17.5.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.6.0:*:*:*:community:*:*:* | 17.6.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.6.0:*:*:*:enterprise:*:*:* | 17.6.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.11.0 to before 17.3.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.11.0 to before 17.3.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.4.0:*:*:*:community:*:*:* Versions 17.4.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.4.0:*:*:*:enterprise:*:*:* Versions 17.4.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.5.0:*:*:*:community:*:*:* Versions 17.5.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.5.0:*:*:*:enterprise:*:*:* Versions 17.5.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.6.0:*:*:*:community:*:*:* Versions 17.6.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.6.0:*:*:*:enterprise:*:*:* Versions 17.6.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab VSCode Fork (GitLab) Fixed in 1.89.1-1.0.0-dev-20241118094343
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10383
- 2026-10-03 Alias added: GHSA-v575-96v9-gxhw
References
Exploit 1
Other 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-10383 · CVE Program
- CVE-2024-10383 · NVD
- FIRST EPSS
- GHSA-v575-96v9-gxhw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences