Stylish Price List < 7.1.12 - Contributor+ Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Stylish Price List WordPress plugin before 7.1.12 does not sanitise and escape some of its settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00323 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Stylish Price List (Unknown): 7.1.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Stylish Price List | before 7.1.12 | 7.1.12 | Patch available | CNA |
- Stylish Price List VendorUnknown Affected before 7.1.12 Fixed in 7.1.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:stylishpricelist:stylish_price_list:*:*:*:*:*:wordpress:*:* | before 7.1.12 | Vulnerable | Stylishpricelist |
- cpe:2.3:a:stylishpricelist:stylish_price_list:*:*:*:*:*:wordpress:*:* Versions before 7.1.12 Vulnerable ·Stylishpricelist
Remediation
- Fix · CNA Stylish Price List (Unknown) Fixed in 7.1.12
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10472
- 2026-10-03 Alias added: GHSA-c993-hrcm-4cp8
References
More Stylishpricelist Stylish Price List vulnerabilities
- TI-2024-07192 Stylish Price List < 7.1.8 - Contributor+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-28320 WordPress Stylish Price List Plugin <= 7.0.17 is vulnerable to Broken Access Control CVSS 3.1CRITICAL 9.8
- TI-2021-07052 Stylish Price List < 6.9.1 - Subscriber+ Arbitrary Image Upload CVSS 3.1MEDIUM 6.5
- TI-2021-07039 Stylish Price List < 6.9.0 - Unauthenticated Arbitrary Image Upload CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-10472 · CVE Program
- CVE-2024-10472 · NVD
- FIRST EPSS
- GHSA-c993-hrcm-4cp8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences