ARForms Builder < 1.7.1 - Unauthenticated Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Contact Form, Survey, Quiz & Popup Form Builder WordPress plugin before 1.7.1 does not sanitise and escape some parameters when outputting them in the page, which could allow unauthenticated users to perform Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00344 28th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Contact Form, Survey, Quiz & Popup Form Builder (Unknown): 1.7.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Contact Form, Survey, Quiz & Popup Form Builder | before 1.7.1 | 1.7.1 | Patch available | CNA |
- Contact Form, Survey, Quiz & Popup Form Builder VendorUnknown Affected before 1.7.1 Fixed in 1.7.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:reputeinfosystems:arforms:*:*:*:*:*:wordpress:*:* | before 1.7.1 | Vulnerable | reputeinfosystems |
- cpe:2.3:a:reputeinfosystems:arforms:*:*:*:*:*:wordpress:*:* Versions before 1.7.1 Vulnerable ·reputeinfosystems
Remediation
- Fix · CNA Contact Form, Survey, Quiz & Popup Form Builder (Unknown) Fixed in 1.7.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10504
- 2026-10-03 Alias added: GHSA-q4jv-p3r8-p9rx
References
More reputeinfosystems Arforms vulnerabilities
- TI-2024-04300 ArForms < 6.6 - Unauthenticated RCE CVSS 3.1CRITICAL 9.8
- TI-2024-00389 Arforms < 6.4.1 - Reflected XSS CVSS 3.1MEDIUM 6.3
- TI-2024-04301 ArForms < 6.6 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2019-12605 In the ARforms plugin 3.7.1 for WordPress, arf_delete_file in arformcontroller.php allows… CVSS 3.1HIGH 7.5
- TI-2024-21586 WordPress ARForms plugin <= 6.4 - Subscriber+ SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-21585 WordPress ARForms plugin <= 6.4 - Subscriber+ Arbitrary Plugin Activation/Deactivation Vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2024-10504 · CVE Program
- CVE-2024-10504 · NVD
- FIRST EPSS
- GHSA-q4jv-p3r8-p9rx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences