Kognetiks Chatbot for WordPress <= 2.1.7 - Missing Authorization to Authenticated (Subscriber+) Assistant Deletion
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Kognetiks Chatbot for WordPress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the delete_assistant() function in all versions up to, and including, 2.1.7. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete GTP assistants.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10529
- 2026-10-03 Alias added: GHSA-7p5h-w4v8-78m4
References
Patch 2
More Kognetiks Chatbot vulnerabilities
- TI-2024-09755 Kognetiks Chatbot for WordPress <= 2.1.7 - Missing Authorization to Authenticated (Subscriber+) Assistant Update CVSS 3.1MEDIUM 5.3
- TI-2024-09902 Kognetiks Chatbot for WordPress <= 2.1.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-10327 Cross-site request forgery in Kognetiks Chatbot for WordPress CVSS 3.1MEDIUM 4.3
- TI-2024-09754 Kognetiks Chatbot for WordPress <= 2.1.7 - Missing Authorization to Authenticated (Subscriber+) Assistant Addition CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-10529 · CVE Program
- CVE-2024-10529 · NVD
- FIRST EPSS
- GHSA-7p5h-w4v8-78m4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences