Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HashiCorp | Nomad | 1.3.0 to before 1.9.2 | 1.9.2 | Patch available | CNA |
| HashiCorp | Nomad Enterprise | 1.3.0 to before 1.9.2 | 1.9.2 | Patch available | CNA |
| — | github.com/hashicorp/nomad (Go) | up to 1.9.1 | — | No fix listed | GHSA-2w5v-x29g-jw7j |
- Nomad VendorHashiCorp Affected 1.3.0 to before 1.9.2 Fixed in 1.9.2 Patch available CNA
- Nomad Enterprise VendorHashiCorp Affected 1.3.0 to before 1.9.2 Fixed in 1.9.2 Patch available CNA
- github.com/hashicorp/nomad (Go) Vendor— Affected up to 1.9.1 Fixed in — No fix listed GHSA-2w5v-x29g-jw7j
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* | 1.3.0 to before 1.7.15 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* | 1.3.0 to before 1.9.2 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* | 1.8.0 to before 1.8.7; 1.9.0 to before 1.9.2 | Vulnerable | HashiCorp |
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* Versions 1.3.0 to before 1.7.15 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* Versions 1.3.0 to before 1.9.2 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* Versions 1.8.0 to before 1.8.7; 1.9.0 to before 1.9.2 Vulnerable ·HashiCorp
Remediation
- Fix · CNA Nomad (HashiCorp) Fixed in 1.9.2
- Fix · CNA Nomad Enterprise (HashiCorp) Fixed in 1.9.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10975
- 2026-10-03 Alias added: GHSA-2w5v-x29g-jw7j
References
Advisory 3
More HashiCorp Nomad vulnerabilities
- TI-2019-09419 HashiCorp Nomad 0.9.0 through 0.9.1 has Incorrect Access Control via the exec driver. CVSS 3.0CRITICAL 9.8
- TI-2022-12559 HashiCorp Nomad and Nomad Enterprise version 0.2.0 up to 1.3.0 were impacted by go-getter… CVSS 3.1CRITICAL 9.8
- TI-2023-01674 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation CVSS 3.1CRITICAL 10.0
- TI-2020-06436 HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region… CVSS 3.1CRITICAL 9.8
- TI-2020-16532 HashiCorp Nomad and Nomad Enterprise version 0.9.0 up to 0.12.5 client file sandbox… CVSS 3.1CRITICAL 9.1
- TI-2021-19357 HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task… CVSS 3.1HIGH 8.8
Sources
- CVE-2024-10975 · CVE Program
- CVE-2024-10975 · NVD
- FIRST EPSS
- GHSA-2w5v-x29g-jw7j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences