OS command injection in needrestart
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
Qualys discovered that needrestart, before version 3.8, passes unsanitized data to a library (Modules::ScanDeps) which expects safe input. This could allow a local attacker to execute arbitrary shell commands. Please see the related CVE-2024-10224 in Modules::ScanDeps.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| needrestart | needrestart | before 3.8 | 3.8 | Patch available | CNA |
- needrestart Vendorneedrestart Affected before 3.8 Fixed in 3.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:needrestart_project:needrestart:*:*:*:*:*:*:*:* | before 3.8 | Vulnerable | needrestart |
- cpe:2.3:a:needrestart_project:needrestart:*:*:*:*:*:*:*:* Versions before 3.8 Vulnerable ·needrestart
Remediation
- Fix · CNA needrestart (needrestart) Fixed in 3.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
needrestart 3.8
4 records Highest priority Priority MEDIUM 4 MEDIUM
Other records, highest priority first
- TI-2024-32665 Uncontrolled search path in needrestartPriority MEDIUM 55
- TI-2024-32667 Uncontrolled search path in needrestartPriority MEDIUM 47
- TI-2024-32666 Race condition in needrestartPriority MEDIUM 45
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-11003
- 2026-10-03 Alias added: GHSA-9f4h-r2c7-m6w4
References
More Needrestart vulnerabilities
- TI-2024-32665 Uncontrolled search path in needrestart CVSS 3.1HIGH 7.8
- TI-2024-32667 Uncontrolled search path in needrestart CVSS 3.1HIGH 7.8
- TI-2024-32666 Race condition in needrestart CVSS 3.1HIGH 7.8
- TI-2022-12824 needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. CVSS 3.1HIGH 7.8
Sources
- CVE-2024-11003 · CVE Program
- CVE-2024-11003 · NVD
- FIRST EPSS
- GHSA-9f4h-r2c7-m6w4 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-11003 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences