Serious Slider < 1.2.7 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Serious Slider WordPress plugin before 1.2.7 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0033 26th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Serious Slider (Unknown): 1.2.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Serious Slider | before 1.2.7 | 1.2.7 | Patch available | CNA |
- Serious Slider VendorUnknown Affected before 1.2.7 Fixed in 1.2.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cryoutcreations:serious_slider:*:*:*:*:*:wordpress:*:* | before 1.2.7 | Vulnerable | CryoutCreations |
- cpe:2.3:a:cryoutcreations:serious_slider:*:*:*:*:*:wordpress:*:* Versions before 1.2.7 Vulnerable ·CryoutCreations
Remediation
- Fix · CNA Serious Slider (Unknown) Fixed in 1.2.7
Timeline
- 2026-10-02 Threatist record created from CVE-2024-11108
- 2026-10-03 Alias added: GHSA-3vx3-2qpf-jvhh
References
More CryoutCreations Serious Slider vulnerabilities
- TI-2024-23631 WordPress Serious Slider plugin <= 1.2.4 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-11108 · CVE Program
- CVE-2024-11108 · NVD
- FIRST EPSS
- GHSA-3vx3-2qpf-jvhh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences