Read the docs
TI-2024-10408 Aliases CVE-2024-11235

Reference counting in php_request_shutdown causes Use-After-Free

Priority HIGH 75CWE-416Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Attack requirements
Present
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 fixed, 2 without a fix

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.

Summary

In PHP versions 8.3.* before 8.3.19 and 8.4.* before 8.4.5, a code sequence involving __set handler or ??=  operator and exceptions can lead to a use-after-free vulnerability. If the third party can control the memory layout leading to this, for example by supplying specially crafted inputs to the script, it could lead to remote code execution.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01482 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial PHP (PHP Group): 8.4.5, 8.3.19Red Hat: 2 advisoriesRed Hat: 2 fixed, 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHP GroupPHPbefore 8.4.5; before 8.3.198.4.5, 8.3.19Patch availableCNA
  • PHP VendorPHP Group Affected before 8.4.5; before 8.3.19 Fixed in 8.4.5, 8.3.19 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*8.3.0 to before 8.3.19; 8.4.0 to before 8.4.5VulnerablePHP
  • cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 8.3.0 to before 8.3.19; 8.4.0 to before 8.4.5 Vulnerable ·PHP

Remediation

  • Fix · CNA PHP (PHP Group) Fixed in 8.4.5, 8.3.19

Red Hat 2 advisories

  • RHSA-2025:7489 Released 2025-05-13 · Red Hat rating Important
    php security update
    • Red Hat Enterprise Linux AppStream (v. 10) php-8.3.19-1.el10_0, php-bcmath-8.3.19-1.el10_0, php-cli-8.3.19-1.el10_0 +22
  • RHSA-2025:7418 Released 2025-05-13 · Red Hat rating Important
    php:8.3 security update
    • Red Hat Enterprise Linux AppStream (v. 9) apcu-panel-5.1.23-1.module+el9.6.0+22647+1741ae35.noarch::php:8.3, php-8.3.19-1.module+el9.6.0+23015+da8065b7.aarch64::php:8.3, php-8.3.19-1.module+el9.6.0+23015+da8065b7.ppc64le::php:8.3 +47

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux AppStream (v. 10)Fixed RHSA-2025:7489
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2025:7418
Not affected: 2 products
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-11235

References

  • TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
  • TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
  • TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
  • TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
  • TI-2024-05189 Command injection via array-ish $command parameter of proc_open() (bypass CVE-2024-1874 fix) CVSS 3.1HIGH 8.8
See all 107 →

Sources