Automation-gateway: aap-gateway: improper scope handling in oauth2 tokens for aap 2.5
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-284.
Summary
A vulnerability was found in the Ansible Automation Platform (AAP). This flaw allows attackers to escalate privileges by improperly leveraging read-scoped OAuth2 tokens to gain write access. This issue affects API endpoints that rely on ansible_base.oauth2_provider for OAuth2 authentication. While the impact is limited to actions within the user’s assigned permissions, it undermines scoped access controls, potentially allowing unintended modifications in the application and consuming services.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | django-ansible-base | up to v2024.10.17 | — | No fix listed | CNA |
| Red Hat | Red Hat Ansible Automation Platform 2.5 for RHEL 8 | — | 2.5.20241218-1.el8ap | Patch available | CNA |
| Red Hat | Red Hat Ansible Automation Platform 2.5 for RHEL 9 | — | 2.5.20241218-1.el9ap | Patch available | CNA |
- django-ansible-base Vendor— Affected up to v2024.10.17 Fixed in — No fix listed CNA
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 VendorRed Hat Affected — Fixed in 2.5.20241218-1.el8ap Patch available CNA
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 VendorRed Hat Affected — Fixed in 2.5.20241218-1.el9ap Patch available CNA
CPE names CNA · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:/a:redhat:ansible_automation_platform:2.5::el9 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform_inside:2.5::el9 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform_inside:2.5::el8 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform_developer:2.5::el8 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform_developer:2.5::el9 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform:2.5::el8 | 2.5 | — | Red Hat |
- cpe:/a:redhat:ansible_automation_platform:2.5::el9 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform_inside:2.5::el9 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform_inside:2.5::el8 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform_developer:2.5::el8 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform_developer:2.5::el9 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform:2.5::el8 Versions 2.5 — ·Red Hat
Remediation
Red Hat 1 advisory
- RHSA-2024:11145 Released 2024-12-16 · Red Hat rating ModerateRed Hat Ansible Automation Platform 2.5 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 ansible-core-1:2.16.14-1.el8ap, automation-gateway-server-2.5.20241218-1.el8ap
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 ansible-core-1:2.16.14-1.el9ap, automation-gateway-server-2.5.20241218-1.el9ap
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | Fixed | RHSA-2024:11145 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 9 | Fixed | RHSA-2024:11145 |
Not affected: 2 products
- Red Hat Ansible Automation Platform 2.5 for RHEL 8
- Red Hat Ansible Automation Platform 2.5 for RHEL 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-11483
- 2026-10-03 Alias added: GHSA-q73v-w388-wp95
References
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-11483 · CVE Program
- CVE-2024-11483 · NVD
- FIRST EPSS
- GHSA-q73v-w388-wp95 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-11483 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences