Insufficient Session Expiration in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-613.
Summary
An issue has been discovered in GitLab CE/EE affecting all versions from 16.11 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1. Long-lived connections could potentially bypass authentication controls, allowing unauthorized access to streaming results.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 16.11 to before 17.4.5; 17.5 to before 17.5.3; 17.6 to before 17.6.1 | 17.4.5, 17.5.3, 17.6.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 16.11 to before 17.4.5; 17.5 to before 17.5.3; 17.6 to before 17.6.1 Fixed in 17.4.5, 17.5.3, 17.6.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.11.0 to before 17.4.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.11.0 to before 17.4.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 17.5.0 to before 17.5.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.5.0 to before 17.5.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.6.0:*:*:*:community:*:*:* | 17.6.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.6.0:*:*:*:enterprise:*:*:* | 17.6.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.11.0 to before 17.4.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.11.0 to before 17.4.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.5.0 to before 17.5.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.5.0 to before 17.5.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.6.0:*:*:*:community:*:*:* Versions 17.6.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.6.0:*:*:*:enterprise:*:*:* Versions 17.6.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 17.4.5, 17.5.3, 17.6.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 17.4.5, 17.5.3, 17.6.1
6 records Highest priority Priority MEDIUM 1 MEDIUM, 5 LOW
Other records, highest priority first
- TI-2024-07523 Missing Authorization in GitLabPriority MEDIUM 41
- TI-2024-10815 Incorrect Authorization in GitLabPriority LOW 35
- TI-2024-10972 Inefficient Algorithmic Complexity in GitLabPriority LOW 34
Timeline
- 2026-10-02 Threatist record created from CVE-2024-11668
- 2026-10-03 Alias added: GHSA-g797-r4r7-wp94
References
Other 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-11668 · CVE Program
- CVE-2024-11668 · NVD
- FIRST EPSS
- GHSA-g797-r4r7-wp94 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences