Remote Code Execution via Model Deserialization in invoke-ai/invokeai
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| invoke-ai | invoke-ai/invokeai | before 5.4.3 | 5.4.3 | Patch available | CNA |
| — | InvokeAI (PyPI) | 5.3.1 to before 5.4.3rc2 | 5.4.3rc2 | Patch available | GHSA-mcrp-whpw-jp68 |
- invoke-ai/invokeai Vendorinvoke-ai Affected before 5.4.3 Fixed in 5.4.3 Patch available CNA
- InvokeAI (PyPI) Vendor— Affected 5.3.1 to before 5.4.3rc2 Fixed in 5.4.3rc2 Patch available GHSA-mcrp-whpw-jp68
Remediation
- Fix · CNA invoke-ai/invokeai (invoke-ai) Fixed in 5.4.3
- Fix · GHSA-mcrp-whpw-jp68 InvokeAI (PyPI) Fixed in 5.4.3rc2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12029
- 2026-10-03 Alias added: GHSA-mcrp-whpw-jp68
References
Other 5
- https://huntr.com/bounties/9b790f94-1b1b-4071-bc27-78445d1a87a3
- https://github.com/invoke-ai/invokeai/commit/756008dc5899081c5aa51e5bd8f24c1b3975a59e
- https://github.com/invoke-ai/InvokeAI/commit/ed46acee79460189b38c164321b14bdfbf3073c9
- https://github.com/invoke-ai/InvokeAI
- https://github.com/pypa/advisory-database/tree/main/vulns/invokeai/PYSEC-2025-9.yaml
More invoke-ai vulnerabilities
- TI-2025-05643 Path Traversal and Arbitrary File Deletion in invoke-ai/invokeai CVSS 3.0CRITICAL 9.8
- TI-2024-10230 Arbitrary File Delete in invoke-ai/invokeai CVSS 3.0CRITICAL 9.1
- TI-2024-10231 Denial of Service (DoS) via Large Payload in Board Name Field in invoke-ai/invokeai CVSS 3.0HIGH 7.5
- TI-2024-10032 Denial of Service (DoS) in invoke-ai/invokeai CVSS 3.0HIGH 7.5
- TI-2026-46450 InvokeAI < 6.13.7 Unauthenticated Directory Enumeration via scan_folder CVSS 4.0MEDIUM 6.3
Sources
- CVE-2024-12029 · CVE Program
- CVE-2024-12029 · NVD
- FIRST EPSS
- GHSA-mcrp-whpw-jp68 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences