Improper Validation of Consistency within Input in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An issue has been discovered in GitLab CE/EE affecting all versions from 11.1 before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. Improper XPath validation allows modified SAML response to bypass 2FA requirement under specialized conditions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 11.1 to before 17.10.7; 17.11 to before 17.11.3; 18.0 to before 18.0.1 | 17.10.7, 17.11.3, 18.0.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 11.1 to before 17.10.7; 17.11 to before 17.11.3; 18.0 to before 18.0.1 Fixed in 17.10.7, 17.11.3, 18.0.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 11.1.0 to before 17.10.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 11.1.0 to before 17.10.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 17.11.0 to before 17.11.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.11.0 to before 17.11.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.0.0:*:*:*:community:*:*:* | 18.0.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.0.0:*:*:*:enterprise:*:*:* | 18.0.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 11.1.0 to before 17.10.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 11.1.0 to before 17.10.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.11.0 to before 17.11.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.11.0 to before 17.11.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.0.0:*:*:*:community:*:*:* Versions 18.0.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.0.0:*:*:*:enterprise:*:*:* Versions 18.0.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 17.10.7, 17.11.3, 18.0.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 17.10.7, 17.11.3, 18.0.1
7 records Highest priority Priority LOW 7 LOW
Other records, highest priority first
- TI-2025-04463 Insufficient Granularity of Access Control in GitLabPriority LOW 33
- TI-2025-00836 Allocation of Resources Without Limits or Throttling in GitLabPriority LOW 33
- TI-2025-02716 Allocation of Resources Without Limits or Throttling in GitLabPriority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12093
- 2026-10-03 Alias added: GHSA-7rfw-87cg-pgwh
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-12093 · CVE Program
- CVE-2024-12093 · NVD
- FIRST EPSS
- GHSA-7rfw-87cg-pgwh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences