Read the docs
TI-2024-11400 Aliases CVE-2024-12290GHSA-4rq5-fqvj-3w68

Infility Global <= 2.9.8 - Reflected Cross-Site Scripting via set_type Parameter

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The Infility Global plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘set_type’ parameter in all versions up to, and including, 2.9.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. CVE-2024-12723 is a duplicate of this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00378 31st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
InfilityInfility Globalup to 2.9.8—No fix listedCNA
  • Infility Global VendorInfility Affected up to 2.9.8 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:infility:infility_global:*:*:*:*:*:wordpress:*:*before 2.9.9VulnerableInfility
  • cpe:2.3:a:infility:infility_global:*:*:*:*:*:wordpress:*:* Versions before 2.9.9 Vulnerable ·Infility

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-12290
  2. 2026-10-03 Alias added: GHSA-4rq5-fqvj-3w68

References

  • TI-2024-11796 Infility Global <= 2.9.8 - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2024-10647 Infility Global <= 2.9.8 - Authenticated (Subscriber+) Missing Authorization to Plugin Options Update CVSS 3.1MEDIUM 6.5

Sources