Command injection in EnerSys AMPA versions 24.04 through 24.16, inclusive
Priority MEDIUM 51CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-77.
Summary
EnerSys AMPA versions 24.04 through 24.16, inclusive, are vulnerable to command injection leading to privileged remote shell access.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01142 66th percentileScored 2026-11-07
Fix Fixed AMPA (EnerSys): 24.17
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA AMPA (EnerSys) Fixed in 24.17
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12442
- 2026-10-03 Alias added: GHSA-p2j9-hh6h-8mxx
References
More EnerSys vulnerabilities
- TI-2024-11004 Command injection in EnerSys AMPA 22.09 and prior versions CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-12442 · CVE Program
- CVE-2024-12442 · NVD
- FIRST EPSS
- GHSA-p2j9-hh6h-8mxx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences