Minify HTML <= 2.1.10 - - Regular Expressions Denial of Service
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-400.
Summary
The Minify HTML plugin for WordPress is vulnerable to Regular Expression Denial of Service (ReDoS) in all versions up to, and including, 2.1.10. This is due to processing user-supplied input as a regular expression. This makes it possible for unauthenticated attackers to create comments that can cause catastrophic backtracking and break pages.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12579
- 2026-10-03 Alias added: GHSA-75pp-9v48-ff5j
References
More teckel vulnerabilities
- TI-2026-02756 Minify HTML <= 2.1.12 - Cross-Site Request Forgery to Plugin Settings Update CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-12579 · CVE Program
- CVE-2024-12579 · NVD
- FIRST EPSS
- GHSA-75pp-9v48-ff5j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences