Passwords Manager <= 1.4.8 - Authenticated (Subscriber+) SQL Injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
The Passwords Manager plugin for WordPress is vulnerable to SQL Injection via the $wpdb->prefix value in several AJAX actions in all versions up to, and including, 1.4.8 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12615
- 2026-10-03 Alias added: GHSA-9gqj-gcg6-fqjj
References
Patch 3
- https://plugins.trac.wordpress.org/changeset/3221505/passwords-manager/trunk/include/pms-passwords-ajax-action.php
- https://plugins.trac.wordpress.org/changeset/3221505/passwords-manager/trunk/include/admin-page/addon/csv-export/index.php
- https://plugins.trac.wordpress.org/changeset/3221505/passwords-manager/trunk/include/pms-categories-ajax-action.php
More coder426 Passwords Manager vulnerabilities
- TI-2024-11705 Passwords Manager <= 1.4.8 - Missing Authorization to Authenticated (Subscriber+) Add Password + Update Encryption Key CVSS 3.1HIGH 7.5
- TI-2024-11704 Passwords Manager <= 1.4.8 - Unauthenticated SQL Injection CVSS 3.1HIGH 7.5
Sources
- CVE-2024-12615 · CVE Program
- CVE-2024-12615 · NVD
- FIRST EPSS
- GHSA-9gqj-gcg6-fqjj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences