DNS-over-HTTPS implementation suffers from multiple issues under heavy query load
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-770.
Summary
Clients using DNS-over-HTTPS (DoH) can exhaust a DNS resolver's CPU and/or memory by flooding it with crafted valid or invalid HTTP/2 traffic. This issue affects BIND 9 versions 9.18.0 through 9.18.32, 9.20.0 through 9.20.4, 9.21.0 through 9.21.3, and 9.18.11-S1 through 9.18.32-S1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Red Hat 2 advisories
- RHSA-2025:1907 Released 2025-03-05 · Red Hat rating ImportantOpenShift Container Platform 4.16.37 security update
- Red Hat OpenShift Container Platform 4.16 rhcos
- RHSA-2025:1670 Released 2025-02-19 · Red Hat rating Importantbind9.18 security update
- Red Hat CodeReady Linux Builder (v. 9) bind9.18-devel-32:9.18.29-1.el9_5.1, bind9.18-doc-32:9.18.29-1.el9_5.1, bind9.18-libs-32:9.18.29-1.el9_5.1
- Red Hat Enterprise Linux AppStream (v. 9) bind9.18-32:9.18.29-1.el9_5.1, bind9.18-chroot-32:9.18.29-1.el9_5.1, bind9.18-dnssec-utils-32:9.18.29-1.el9_5.1 +2
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2025:1670 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:1670 |
| Red Hat OpenShift Container Platform 4.16 | Fixed | RHSA-2025:1907 |
Not affected: 7 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat OpenShift Container Platform 4
- Red Hat OpenShift Container Platform 4.16
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12705
- 2026-10-03 Alias added: GHSA-gf34-2fpp-vmc4
References
Advisory 1
More ISC vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
Sources
- CVE-2024-12705 · CVE Program
- CVE-2024-12705 · NVD
- FIRST EPSS
- GHSA-gf34-2fpp-vmc4 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-12705 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences