WP BASE Booking of Appointments, Services and Events < 5.0.0 - Reflected XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP BASE Booking of Appointments, Services and Events WordPress plugin before 5.0.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00601 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP BASE Booking of Appointments, Services and Events (Unknown): 5.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP BASE Booking of Appointments, Services and Events | before 5.0.0 | 5.0.0 | Patch available | CNA |
- WP BASE Booking of Appointments, Services and Events VendorUnknown Affected before 5.0.0 Fixed in 5.0.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-base:wp_base_booking_of_appointments\,_services_and_events:*:*:*:*:*:wordpress:*:* | before 5.0.0 | Vulnerable | WP BASE |
- cpe:2.3:a:wp-base:wp_base_booking_of_appointments\,_services_and_events:*:*:*:*:*:wordpress:*:* Versions before 5.0.0 Vulnerable ·WP BASE
Remediation
- Fix · CNA WP BASE Booking of Appointments, Services and Events (Unknown) Fixed in 5.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12737
- 2026-10-03 Alias added: GHSA-7ggj-vx66-73fv
References
Sources
- CVE-2024-12737 · CVE Program
- CVE-2024-12737 · NVD
- FIRST EPSS
- GHSA-7ggj-vx66-73fv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences