DrayTek Vigor2960/Vigor300B Web Management Interface apmcfgupload os command injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-77.
Summary
A vulnerability, which was classified as critical, was found in DrayTek Vigor2960 and Vigor300B 1.5.1.4. Affected is an unknown function of the file /cgi-bin/mainfunction.cgi/apmcfgupload of the component Web Management Interface. The manipulation of the argument session leads to os command injection. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.5.1.5 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DrayTek | Vigor2960 | 1.5.1.4 | — | No fix listed | CNA |
| DrayTek | Vigor300B | 1.5.1.4 | — | No fix listed | CNA |
- Vigor2960 VendorDrayTek Affected 1.5.1.4 Fixed in — No fix listed CNA
- Vigor300B VendorDrayTek Affected 1.5.1.4 Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:draytek:vigor300b_firmware:1.5.1.4:*:*:*:*:*:*:* | 1.5.1.4 | Vulnerable | DrayTek |
| cpe:2.3:h:draytek:vigor300b:-:*:*:*:*:*:*:* | not specified by NVD | Running on | DrayTek |
| cpe:2.3:o:draytek:vigor2960_firmware:1.5.1.4:*:*:*:*:*:*:* | 1.5.1.4 | Vulnerable | DrayTek |
| cpe:2.3:h:draytek:vigor2960:-:*:*:*:*:*:*:* | not specified by NVD | Running on | DrayTek |
- cpe:2.3:o:draytek:vigor300b_firmware:1.5.1.4:*:*:*:*:*:*:* Versions 1.5.1.4 Vulnerable ·DrayTek
- cpe:2.3:h:draytek:vigor300b:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·DrayTek
- cpe:2.3:o:draytek:vigor2960_firmware:1.5.1.4:*:*:*:*:*:*:* Versions 1.5.1.4 Vulnerable ·DrayTek
- cpe:2.3:h:draytek:vigor2960:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·DrayTek
Remediation
No fixed version listed by the sources yet.
Timeline
- 2025-05-15 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2024-12987
- 2026-10-03 Alias added: GHSA-3mp3-6fg3-7hxj
References
More DrayTek Vigor2960 Firmware vulnerabilities
- TI-2020-12150 On DrayTek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-06834 DrayTek Vigor2960 1.3.1_Beta, Vigor3900 1.4.4_Beta, and Vigor300B 1.3.3_Beta… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-08715 A stack-based buffer overflow in cvmd on Draytek Vigor3900, Vigor2960, and Vigor300B… CVSS 3.1CRITICAL 9.8
- TI-2020-08714 A stack-based buffer overflow in apmd on Draytek Vigor3900, Vigor2960, and Vigor300B… CVSS 3.1CRITICAL 9.8
- TI-2020-08713 /cgi-bin/activate.cgi on Draytek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1… CVSS 3.1CRITICAL 9.8
- TI-2020-08712 A stack-based buffer overflow in /cgi-bin/activate.cgi while base64 decoding ticket… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-12987 · CVE Program
- CVE-2024-12987 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-3mp3-6fg3-7hxj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences