WP Google Map < 1.9.4 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Maps Plugin using Google Maps for WordPress WordPress plugin before 1.9.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Maps Plugin using Google Maps for WordPress | before 1.9.4 | 1.9.4 | Patch available | CNA |
- Maps Plugin using Google Maps for WordPress VendorUnknown Affected before 1.9.4 Fixed in 1.9.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpgooglemap:wp_google_map:*:*:*:*:*:wordpress:*:* | before 1.9.4 | Vulnerable | WP Google Map |
- cpe:2.3:a:wpgooglemap:wp_google_map:*:*:*:*:*:wordpress:*:* Versions before 1.9.4 Vulnerable ·WP Google Map
Remediation
- Fix · CNA Maps Plugin using Google Maps for WordPress (Unknown) Fixed in 1.9.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Maps Plugin using Google Maps for WordPress 1.9.4
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-12254 WP Google Map < 1.9.4 - Admin+ Stored XSSPriority MEDIUM 53
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13306
- 2026-10-03 Alias added: GHSA-j27x-pp9j-vhj8
References
More Wp Google Map vulnerabilities
- TI-2024-12254 WP Google Map < 1.9.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.3
- TI-2021-07359 WP Google Map < 1.8.4 - Arbitrary Post Deletion and Plugin's Settings Update via CSRF CVSS 3.1MEDIUM 6.5
- TI-2021-07289 WP Google Map < 1.8.1 - Subscriber+ Arbitrary Post Deletion and Plugin's Settings Update CVSS 3.1MEDIUM 5.7
Sources
- CVE-2024-13306 · CVE Program
- CVE-2024-13306 · NVD
- FIRST EPSS
- GHSA-j27x-pp9j-vhj8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences