Read the docs
TI-2024-12478 Aliases CVE-2024-13437GHSA-qvgr-349g-pv28

Book a Room <= 2.9 - Cross-Site Request Forgery to Settings Update

Priority LOW 19CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

The Book a Room plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.9. This is due to missing or incorrect nonce validation on the 'bookaroom_Settings' page. This makes it possible for unauthenticated attackers to update the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00163 5th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
chuhplBook a Roomup to 2.9—No fix listedCNA
  • Book a Room Vendorchuhpl Affected up to 2.9 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:heightslibrary:book_a_room:*:*:*:*:*:*:*:*up to 2.9VulnerableHeightslibrary
  • cpe:2.3:a:heightslibrary:book_a_room:*:*:*:*:*:*:*:* Versions up to 2.9 Vulnerable ·Heightslibrary

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-13437
  2. 2026-10-03 Alias added: GHSA-qvgr-349g-pv28

References

  • TI-2026-08519 Book a Room Event Calendar <= 1.9 - Cross-Site Request Forgery to Settings Update CVSS 3.1MEDIUM 4.3

Sources