Read the docs
TI-2024-12550 Aliases CVE-2024-13509GHSA-qqrp-rh67-96r2

WS Form LITE and PRO <= 1.10.13 - Unauthenticated Stored Cross-Site Scripting

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The WS Form LITE and PRO plugins for WordPress are vulnerable to Stored Cross-Site Scripting via the url parameter in all versions up to, and including, 1.10.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability is partially fixed in 1.10.13 and completely fixed in 1.10.14.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00368 30th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
westguardWS Form LITE – Drag & Drop Contact Form Builderup to 1.10.13—No fix listedCNA
westguardWS Form Proup to 1.10.13—No fix listedCNA
  • WS Form LITE – Drag & Drop Contact Form Builder Vendorwestguard Affected up to 1.10.13 Fixed in — No fix listed CNA
  • WS Form Pro Vendorwestguard Affected up to 1.10.13 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:westguardsolutions:ws_form:*:*:*:*:lite:wordpress:*:*before 1.10.14Vulnerablewestguard
  • cpe:2.3:a:westguardsolutions:ws_form:*:*:*:*:lite:wordpress:*:* Versions before 1.10.14 Vulnerable ·westguard

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-13509
  2. 2026-10-03 Alias added: GHSA-qqrp-rh67-96r2

References

  • TI-2023-04993 WS Form LITE <= 1.9.217 - Unauthenticated CSV Injection CVSS 3.1HIGH 8.8
  • TI-2023-28574 WordPress WS Form LITE Plugin <= 1.9.170 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
  • TI-2022-07951 WS Form < 1.8.176 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2024-09865 WS Form LITE – Drag & Drop Contact Form Builder for WordPress <= 1.9.244 - Reflected Cross-Site Scripting via URL CVSS 3.1MEDIUM 6.1
  • TI-2022-07950 WS Form < 1.8.176 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8

Sources