Cross-site scripting in BuddyBoss Platform
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Buddyboss Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘bp_nouveau_ajax_media_save’ function in all versions up to, and including, 2.8.50 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.8.41.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13859
- 2026-10-03 Alias added: GHSA-jwhw-fx3f-p3m6
References
More Buddyboss Platform vulnerabilities
- TI-2025-01654 BuddyBoss Platform Pro <= 2.7.01 - Authentication Bypass via Apple OAuth provider CVSS 3.1CRITICAL 9.8
- TI-2024-11831 BuddyBoss platform < 2.7.60 - Private Comment Exposure via IDOR CVSS 3.1LOW 3.5
- TI-2024-12881 BuddyBoss Platform <= 2.8.50 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'bbp_topic_title' CVSS 3.1MEDIUM 6.4
- TI-2024-12879 Cross-site scripting in BuddyBoss Theme CVSS 3.1MEDIUM 6.4
- TI-2024-12444 BuddyBoss Platform <= 2.7.70 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'link_title' CVSS 3.1MEDIUM 6.4
- TI-2024-04542 BuddyBoss Platform < 2.6.0 - Subscriber+ Comment on Private Post via IDOR CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-13859 · CVE Program
- CVE-2024-13859 · NVD
- FIRST EPSS
- GHSA-jwhw-fx3f-p3m6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences