Nagios XI < 2024R1.1.2 Reflected XSS via Login Page on Older Browsers
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Nagios XI versions prior to < 2024R1.1.2 are vulnerable to a reflected cross-site scripting (XSS) via the login page when accessed with older web browsers. Insufficient validation or escaping of user-supplied input reflected by the login page can allow an attacker to craft a malicious link that, when visited by a victim, executes arbitrary JavaScript in the victim’s browser within the Nagios XI origin. The issue is observable under legacy browser behaviors; modern browsers may mitigate some vectors.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Nagios | XI | before 2024R1.1.2 | 2024R1.1.2 | Patch available | CNA |
- XI VendorNagios Affected before 2024R1.1.2 Fixed in 2024R1.1.2 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nagios:nagios_xi:*:*:*:*:*:*:*:* | before 2024 | Vulnerable | Nagios |
| cpe:2.3:a:nagios:nagios_xi:2024:r1:*:*:*:*:*:* | 2024 r1 | Vulnerable | Nagios |
| cpe:2.3:a:nagios:nagios_xi:2024:r1.0.1:*:*:*:*:*:* | 2024 r1.0.1 | Vulnerable | Nagios |
| cpe:2.3:a:nagios:nagios_xi:2024:r1.1:*:*:*:*:*:* | 2024 r1.1 | Vulnerable | Nagios |
| cpe:2.3:a:nagios:nagios_xi:2024:r1.1.1:*:*:*:*:*:* | 2024 r1.1.1 | Vulnerable | Nagios |
- cpe:2.3:a:nagios:nagios_xi:*:*:*:*:*:*:*:* Versions before 2024 Vulnerable ·Nagios
- cpe:2.3:a:nagios:nagios_xi:2024:r1:*:*:*:*:*:* Versions 2024 r1 Vulnerable ·Nagios
- cpe:2.3:a:nagios:nagios_xi:2024:r1.0.1:*:*:*:*:*:* Versions 2024 r1.0.1 Vulnerable ·Nagios
- cpe:2.3:a:nagios:nagios_xi:2024:r1.1:*:*:*:*:*:* Versions 2024 r1.1 Vulnerable ·Nagios
- cpe:2.3:a:nagios:nagios_xi:2024:r1.1.1:*:*:*:*:*:* Versions 2024 r1.1.1 Vulnerable ·Nagios
Remediation
- Fix · CNA XI (Nagios) Fixed in 2024R1.1.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Nagios XI 2024R1.1.2
3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2024-12997 Nagios XI < 2024R1.1.2 Allow Insecure Logins Missing AuthorizationPriority MEDIUM 47
- TI-2024-12998 Nagios XI < 2024R1.1.2 API Keys & Hashed Passwords Authenticated Information DisclosurePriority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13993
- 2026-10-03 Alias added: GHSA-f59v-q7cp-mw78
References
More Nagios Xi vulnerabilities
- TI-2021-07545 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2021-07544 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2021-07543 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2019-11993 Nagios XI before 5.6.6 allows remote command execution as root. KEVCVSS 3.1HIGH 8.8
- TI-2023-26027 Nagios XI before version 5.11.3 was discovered to contain a remote code execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2018-11196 Snoopy 1.0 in Nagios XI 5.5.6 allows remote unauthenticated attackers to execute… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-13993 · CVE Program
- CVE-2024-13993 · NVD
- FIRST EPSS
- GHSA-f59v-q7cp-mw78 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences