Improper input validation in mysql2
Priority HIGH 68CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Versions of the package mysql2 before 3.9.3 are vulnerable to Improper Input Validation through the keyFromFields function, resulting in cache poisoning. An attacker can inject a colon (:) character within a value of the attacker-crafted key.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00744 55th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed mysql2: 3.9.3mysql2 (npm): 3.9.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | mysql2 | before 3.9.3 | 3.9.3 | Patch available | CNA |
| — | mysql2 (npm) | before 3.9.3 | 3.9.3 | Patch available | GHSA-mqr2-w7wj-jjgr |
- mysql2 Vendor— Affected before 3.9.3 Fixed in 3.9.3 Patch available CNA
- mysql2 (npm) Vendor— Affected before 3.9.3 Fixed in 3.9.3 Patch available GHSA-mqr2-w7wj-jjgr
Remediation
- Fix · CNA mysql2 Fixed in 3.9.3
- Fix · GHSA-mqr2-w7wj-jjgr mysql2 (npm) Fixed in 3.9.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Developer Hub 1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21507
- 2026-10-03 Alias added: GHSA-mqr2-w7wj-jjgr
- 2026-10-27 Affected versions changed · Red Hat
References
Exploit 2
More Sidorares Mysql2 vulnerabilities
- TI-2024-14265 Prototype pollution in mysql2 CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-21507 · CVE Program
- CVE-2024-21507 · NVD
- FIRST EPSS
- GHSA-mqr2-w7wj-jjgr · GitHub Advisory Database · CC BY 4.0
- CVE-2024-21507 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences