Code injection in lilconfig
Priority HIGH 75CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Versions of the package lilconfig from 3.1.0 and before 3.1.1 are vulnerable to Arbitrary Code Execution due to the insecure usage of eval in the dynamicImport function. An attacker can exploit this vulnerability by passing a malicious input through the defaultLoaders function.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0113 66th percentileScored 2026-11-07
Fix Fixed lilconfig: 3.1.1org.webjars.npm:lilconfig: 3.1.1+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | lilconfig | 3.1.0 to before 3.1.1 | 3.1.1 | Patch available | CNA |
| — | org.webjars.npm:lilconfig | 3.1.0 to before 3.1.1 | 3.1.1 | Patch available | CNA |
| — | lilconfig (npm) | 3.1.0 to before 3.1.1 | 3.1.1 | Patch available | GHSA-fq9m-v26v-2m4f |
- lilconfig Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available CNA
- org.webjars.npm:lilconfig Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available CNA
- lilconfig (npm) Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-fq9m-v26v-2m4f
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:antonk52:lilconfig:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:antonk52:lilconfig:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
- Fix · CNA lilconfig Fixed in 3.1.1
- Fix · CNA org.webjars.npm:lilconfig Fixed in 3.1.1
- Fix · GHSA-fq9m-v26v-2m4f lilconfig (npm) Fixed in 3.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21537
- 2026-10-03 Alias added: GHSA-fq9m-v26v-2m4f
References
Sources
- CVE-2024-21537 · CVE Program
- CVE-2024-21537 · NVD
- FIRST EPSS
- GHSA-fq9m-v26v-2m4f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences