Improper authentication in djoser
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass, Spoofing
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287 and CWE-295.
Summary
Versions of the package djoser before 2.3.0 are vulnerable to Authentication Bypass when the authenticate() function fails. This is because the system falls back to querying the database directly, granting access to users with valid credentials, and eventually bypassing custom authentication checks such as two-factor authentication, LDAP validations, or requirements from configured AUTHENTICATION_BACKENDS.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | djoser | before 2.3.0 | 2.3.0 | Patch available | CNA |
| — | djoser (PyPI) | before 2.3.0 | 2.3.0 | Patch available | GHSA-v49p-m6gh-747c |
- djoser Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available CNA
- djoser (PyPI) Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available GHSA-v49p-m6gh-747c
Remediation
- Fix · CNA djoser Fixed in 2.3.0
- Fix · GHSA-v49p-m6gh-747c djoser (PyPI) Fixed in 2.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21543
- 2026-10-03 Alias added: GHSA-v49p-m6gh-747c
References
Other 7
- https://github.com/sunscrapers/djoser/releases/tag/2.3.0
- https://github.com/sunscrapers/djoser/issues/795
- https://github.com/sunscrapers/djoser/pull/819
- https://github.com/sunscrapers/djoser/commit/d33c3993c0c735f23cbedc60fa59fce69354f19d
- https://github.com/pypa/advisory-database/tree/main/vulns/djoser/PYSEC-2024-158.yaml
- https://github.com/sunscrapers/djoser
- https://lists.debian.org/debian-lts-announce/2025/02/msg00023.html
Sources
- CVE-2024-21543 · CVE Program
- CVE-2024-21543 · NVD
- FIRST EPSS
- GHSA-v49p-m6gh-747c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences