Improper input validation in spatie/browsershot
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Versions of the package spatie/browsershot before 5.0.1 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method. An attacker can exploit this vulnerability by using leading whitespace (%20) before the file:// protocol, resulting in Local File Inclusion, which allows the attacker to read sensitive files on the server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | spatie/browsershot | before 5.0.1 | 5.0.1 | Patch available | CNA |
| — | spatie/browsershot (Packagist) | before 5.0.1 | 5.0.1 | Patch available | GHSA-g2r4-phv7-5fgv |
- spatie/browsershot Vendor— Affected before 5.0.1 Fixed in 5.0.1 Patch available CNA
- spatie/browsershot (Packagist) Vendor— Affected before 5.0.1 Fixed in 5.0.1 Patch available GHSA-g2r4-phv7-5fgv
Remediation
- Fix · CNA spatie/browsershot Fixed in 5.0.1
- Fix · GHSA-g2r4-phv7-5fgv spatie/browsershot (Packagist) Fixed in 5.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21544
- 2026-10-03 Alias added: GHSA-g2r4-phv7-5fgv
References
Sources
- CVE-2024-21544 · CVE Program
- CVE-2024-21544 · NVD
- FIRST EPSS
- GHSA-g2r4-phv7-5fgv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences