Denial of Service Vulnerability in StorageGRID (formerly StorageGRID Webscale)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-248.
Summary
StorageGRID (formerly StorageGRID Webscale) versions prior to 11.8 are susceptible to a Denial of Service (DoS) vulnerability. Successful exploit by an authenticated attacker could lead to an out of memory condition or node reboot.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA StorageGRID (NetApp) Fixed in 11.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
NetApp StorageGRID 11.8
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2024-14616 Reflected Cross-Site Scripting Vulnerability in StorageGRID (formerly StorageGRID Webscale)Priority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21983
- 2026-10-03 Alias added: GHSA-3xcm-h7jg-4xm5
References
More NetApp Storagegrid vulnerabilities
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2021-17490 mod_proxy SSRF KEVCVSS 3.1CRITICAL 9.0
- TI-2025-18946 Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential) CVSS 4.0CRITICAL 9.3
- TI-2025-18945 ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential) CVSS 4.0CRITICAL 9.3
- TI-2022-00687 Infinite loop in BN_mod_sqrt() reachable when parsing certificates CVSS 3.1HIGH 7.5
- TI-2017-11487 Improper input validation in Apache HTTP Server CVSS 3.0HIGH 8.1
Sources
- CVE-2024-21983 · CVE Program
- CVE-2024-21983 · NVD
- FIRST EPSS
- GHSA-3xcm-h7jg-4xm5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences