CVE-2024-21988 SSH Cryptographic Implementation Vulnerability in StorageGRID (formerly StorageGRID Webscale)
Priority LOW 24CWE-347Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-347.
Summary
StorageGRID (formerly StorageGRID Webscale) versions prior to 11.7.0.9 and 11.8.0.5 are susceptible to disclosure of sensitive information via complex MiTM attacks due to a vulnerability in the SSH cryptographic implementation.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00235 14th percentileScored 2026-11-07
Fix Fixed StorageGRID (formerly StorageGRID Webscale) (NetApp): 11.7.0.9, 11.8.0.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NetApp | StorageGRID (formerly StorageGRID Webscale) | before 11.7.0.9; before 11.8.0.5 | 11.7.0.9, 11.8.0.5 | Patch available | CNA |
- StorageGRID (formerly StorageGRID Webscale) VendorNetApp Affected before 11.7.0.9; before 11.8.0.5 Fixed in 11.7.0.9, 11.8.0.5 Patch available CNA
Remediation
- Fix · CNA StorageGRID (formerly StorageGRID Webscale) (NetApp) Fixed in 11.7.0.9, 11.8.0.5
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21988
- 2026-10-03 Alias added: GHSA-9x5q-pwr2-hwvp
References
More NetApp Storagegrid vulnerabilities
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2021-17490 mod_proxy SSRF KEVCVSS 3.1CRITICAL 9.0
- TI-2025-18946 Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential) CVSS 4.0CRITICAL 9.3
- TI-2025-18945 ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential) CVSS 4.0CRITICAL 9.3
- TI-2022-00687 Infinite loop in BN_mod_sqrt() reachable when parsing certificates CVSS 3.1HIGH 7.5
- TI-2017-11487 Improper input validation in Apache HTTP Server CVSS 3.0HIGH 8.1
Sources
- CVE-2024-21988 · CVE Program
- CVE-2024-21988 · NVD
- FIRST EPSS
- GHSA-9x5q-pwr2-hwvp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences