Read the docs
TI-2024-14623 Aliases CVE-2024-21994GHSA-m8v2-5x3v-f8v7

CVE-2024-21994 Denial of Service Vulnerability in StorageGRID (formerly StorageGRID Webscale)

Priority LOW 20CWE-770Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-770.

Summary

StorageGRID (formerly StorageGRID Webscale) versions prior to 11.9 are susceptible to a Denial of Service (DoS) vulnerability. Successful exploit by an authenticated attacker could lead to a service crash.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00361 30th percentileScored 2026-11-07
Fix Fixed StorageGRID (NetApp): 11.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
NetAppStorageGRIDbefore 11.9.011.9.0Patch availableCNA
  • StorageGRID VendorNetApp Affected before 11.9.0 Fixed in 11.9.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:netapp:storagegrid:*:*:*:*:*:*:*:*before 11.9.0VulnerableNetApp
  • cpe:2.3:a:netapp:storagegrid:*:*:*:*:*:*:*:* Versions before 11.9.0 Vulnerable ·NetApp

Remediation

  • Fix · CNA StorageGRID (NetApp) Fixed in 11.9.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-21994
  2. 2026-10-03 Alias added: GHSA-m8v2-5x3v-f8v7

References

  • TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-17490 mod_proxy SSRF KEVCVSS 3.1CRITICAL 9.0
  • TI-2025-18946 Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential) CVSS 4.0CRITICAL 9.3
  • TI-2025-18945 ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential) CVSS 4.0CRITICAL 9.3
  • TI-2022-00687 Infinite loop in BN_mod_sqrt() reachable when parsing certificates CVSS 3.1HIGH 7.5
  • TI-2017-11487 Improper input validation in Apache HTTP Server CVSS 3.0HIGH 8.1
See all 72 →

Sources