obs-service-download_url is vulnerable to argument injection
Priority LOW 25CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
The OBS service obs-service-download_url was vulnerable to a command injection vulnerability. The attacker could provide a configuration to the service that allowed to execute command in later steps
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00936 61st percentileScored 2026-11-07
Fix Fixed SUSE Package Hub 15 SP5 (SUSE): 0.2.1-bp155.3.3.1SUSE Package Hub 15 SP6 (SUSE): 0.2.1-bp156.2.3.1+3 more products
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Package Hub 15 SP5 | ? to before 0.2.1-bp155.3.3.1 | 0.2.1-bp155.3.3.1 | Patch available | CNA |
| SUSE | SUSE Package Hub 15 SP6 | ? to before 0.2.1-bp156.2.3.1 | 0.2.1-bp156.2.3.1 | Patch available | CNA |
| SUSE | openSUSE Leap 15.5 | ? to before 0.2.1-bp155.3.3.1 | 0.2.1-bp155.3.3.1 | Patch available | CNA |
| SUSE | openSUSE Leap 15.6 | ? to before 0.2.1-bp156.2.3.1 | 0.2.1-bp156.2.3.1 | Patch available | CNA |
| SUSE | openSUSE Tumbleweed | ? to before 0.2.1-1.1 | 0.2.1-1.1 | Patch available | CNA |
- SUSE Package Hub 15 SP5 VendorSUSE Affected ? to before 0.2.1-bp155.3.3.1 Fixed in 0.2.1-bp155.3.3.1 Patch available CNA
- SUSE Package Hub 15 SP6 VendorSUSE Affected ? to before 0.2.1-bp156.2.3.1 Fixed in 0.2.1-bp156.2.3.1 Patch available CNA
- openSUSE Leap 15.5 VendorSUSE Affected ? to before 0.2.1-bp155.3.3.1 Fixed in 0.2.1-bp155.3.3.1 Patch available CNA
- openSUSE Leap 15.6 VendorSUSE Affected ? to before 0.2.1-bp156.2.3.1 Fixed in 0.2.1-bp156.2.3.1 Patch available CNA
- openSUSE Tumbleweed VendorSUSE Affected ? to before 0.2.1-1.1 Fixed in 0.2.1-1.1 Patch available CNA
Remediation
- Fix · CNA SUSE Package Hub 15 SP5 (SUSE) Fixed in 0.2.1-bp155.3.3.1
- Fix · CNA SUSE Package Hub 15 SP6 (SUSE) Fixed in 0.2.1-bp156.2.3.1
- Fix · CNA openSUSE Leap 15.5 (SUSE) Fixed in 0.2.1-bp155.3.3.1
- Fix · CNA openSUSE Leap 15.6 (SUSE) Fixed in 0.2.1-bp156.2.3.1
- Fix · CNA openSUSE Tumbleweed (SUSE) Fixed in 0.2.1-1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22033
- 2026-10-03 Alias added: GHSA-gq45-2xpx-vvv2
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-22033 · CVE Program
- CVE-2024-22033 · NVD
- FIRST EPSS
- GHSA-gq45-2xpx-vvv2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences