CommonMarker Integer Overflow Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-190 and the CVSS impact.
Summary
CommonMarker versions prior to 0.23.4 are at risk of an integer overflow vulnerability. This vulnerability can result in possibly unauthenticated remote attackers to cause heap memory corruption, potentially leading to an information leak or remote code execution, via parsing tables with marker rows that contain more than UINT16_MAX columns.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | commonmarker | before 0.23.4 | 0.23.4 | Patch available | CNA |
| — | commonmarker (RubyGems) | before 0.23.4 | 0.23.4 | Patch available | GHSA-fmx4-26r3-wxpf |
- commonmarker Vendor— Affected before 0.23.4 Fixed in 0.23.4 Patch available CNA
- commonmarker (RubyGems) Vendor— Affected before 0.23.4 Fixed in 0.23.4 Patch available GHSA-fmx4-26r3-wxpf
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:cmark-gfm:*:*:*:*:*:*:*:* | before 0.28.3.gfm.21; 0.29.0.gfm.0 to before 0.29.0.gfm.3 | Vulnerable | GitHub |
| cpe:2.3:a:gjtorikian:commonmarker:*:*:*:*:*:ruby:*:* | before 0.23.4 | Vulnerable | Gjtorikian |
- cpe:2.3:a:github:cmark-gfm:*:*:*:*:*:*:*:* Versions before 0.28.3.gfm.21; 0.29.0.gfm.0 to before 0.29.0.gfm.3 Vulnerable ·GitHub
- cpe:2.3:a:gjtorikian:commonmarker:*:*:*:*:*:ruby:*:* Versions before 0.23.4 Vulnerable ·Gjtorikian
Remediation
- Fix · CNA commonmarker Fixed in 0.23.4
- Fix · GHSA-fmx4-26r3-wxpf commonmarker (RubyGems) Fixed in 0.23.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22051
- 2026-10-03 Alias added: GHSA-fmx4-26r3-wxpf
References
Advisory 4
Sources
- CVE-2024-22051 · CVE Program
- CVE-2024-22051 · NVD
- FIRST EPSS
- GHSA-fmx4-26r3-wxpf · GitHub Advisory Database · CC BY 4.0
- CVE-2024-22051 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences