Cross-Site Scripting (XSS) vulnerability in SAP Companion
Priority LOW 33CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
SAP Companion - version <3.1.38, has a URL with parameter that could be vulnerable to XSS attack. The attacker could send a malicious link to a user that would possibly allow an attacker to retrieve the sensitive information and cause minor impact on the integrity of the web application.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00323 25th percentileScored 2026-11-07
Fix Fixed SAP Companion (SAP_SE): 3.1.38
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA SAP Companion (SAP_SE) Fixed in 3.1.38
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22129
- 2026-10-03 Alias added: GHSA-m53r-gw8p-792j
References
Sources
- CVE-2024-22129 · CVE Program
- CVE-2024-22129 · NVD
- FIRST EPSS
- GHSA-m53r-gw8p-792j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences