Read the docs
TI-2024-14804 Aliases CVE-2024-22212

Nextcloud global site selector authentication bypass

Priority MEDIUM 44CWE-306Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-306.

Summary

Nextcloud Global Site Selector is a tool which allows you to run multiple small Nextcloud instances and redirect users to the right server. A problem in the password verification method allows an attacker to authenticate as another user. It is recommended that the Nextcloud Global Site Selector is upgraded to version 1.4.1, 2.1.2, 2.3.4 or 2.4.5. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00755 55th percentileScored 2026-11-07
Fix Fixed security-advisories (nextcloud): 1.4.1, 2.1.2, 2.3.4 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
nextcloudsecurity-advisories1.1.0 to before 1.4.1; 2.0.0 to before 2.1.2; 2.2.0 to before 2.3.4; 2.4.0 to before 2.4.51.4.1, 2.1.2, 2.3.4, 2.4.5Patch availableCNA
  • security-advisories Vendornextcloud Affected 1.1.0 to before 1.4.1; 2.0.0 to before 2.1.2; 2.2.0 to before 2.3.4; 2.4.0 to before 2.4.5 Fixed in 1.4.1, 2.1.2, 2.3.4, 2.4.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:nextcloud:global_site_selector:*:*:*:*:*:*:*:*1.1.0 to before 1.4.1; 2.0.0 to before 2.1.2; 2.2.0 to before 2.3.4; 2.4.0 to before 2.4.5Vulnerablenextcloud
  • cpe:2.3:a:nextcloud:global_site_selector:*:*:*:*:*:*:*:* Versions 1.1.0 to before 1.4.1; 2.0.0 to before 2.1.2; 2.2.0 to before 2.3.4; 2.4.0 to before 2.4.5 Vulnerable ·nextcloud

Remediation

  • Fix · CNA security-advisories (nextcloud) Fixed in 1.4.1, 2.1.2, 2.3.4, 2.4.5

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-22212

References

Sources