CVE-2024-22258: PKCE Downgrade in Spring Authorization Server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients. Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant. An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Spring | 1.0.x to before 1.0.6; 1.1.x to before 1.1.6; 1.2.x to before 1.2.3 | 1.0.6, 1.1.6, 1.2.3 | Patch available | CNA |
| — | org.springframework.security:spring-security-oauth2-authorization-server (Maven) | before 1.1.6 | 1.1.6 | Patch available | GHSA-x637-x8p3-5p22 |
| — | org.springframework.security:spring-security-oauth2-authorization-server (Maven) | 1.2.0 to before 1.2.3 | 1.2.3 | Patch available | GHSA-x637-x8p3-5p22 |
- Spring VendorVMware Affected 1.0.x to before 1.0.6; 1.1.x to before 1.1.6; 1.2.x to before 1.2.3 Fixed in 1.0.6, 1.1.6, 1.2.3 Patch available CNA
- org.springframework.security:spring-security-oauth2-authorization-server (Maven) Vendor— Affected before 1.1.6 Fixed in 1.1.6 Patch available GHSA-x637-x8p3-5p22
- org.springframework.security:spring-security-oauth2-authorization-server (Maven) Vendor— Affected 1.2.0 to before 1.2.3 Fixed in 1.2.3 Patch available GHSA-x637-x8p3-5p22
Remediation
- Fix · CNA Spring (Spring) Fixed in 1.0.6, 1.1.6, 1.2.3
- Fix · GHSA-x637-x8p3-5p22 org.springframework.security:spring-security-oauth2-authorization-server (Maven) Fixed in 1.1.6 Advisory →
- Fix · GHSA-x637-x8p3-5p22 org.springframework.security:spring-security-oauth2-authorization-server (Maven) Fixed in 1.2.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22258
- 2026-10-03 Alias added: GHSA-x637-x8p3-5p22
References
More VMware vulnerabilities
- TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-22258 · CVE Program
- CVE-2024-22258 · NVD
- FIRST EPSS
- GHSA-x637-x8p3-5p22 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences