Read the docs
TI-2024-14974 Aliases CVE-2024-22400

Open redirect in user_saml via RelayState parameter in Nextcloud User Saml

Priority LOW 28CWE-601Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Spoofing
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-601.

Summary

Nextcloud User Saml is an app for authenticating Nextcloud users using SAML. In affected versions users can be given a link to the Nextcloud server and end up on a uncontrolled thirdparty server. It is recommended that the User Saml app is upgraded to version 5.1.5, 5.2.5, or 6.0.1. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00454 39th percentileScored 2026-11-07
Fix Fixed security-advisories (nextcloud): 5.1.5, 5.2.5, 6.0.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
nextcloudsecurity-advisories5.0.0 to before 5.1.5; 5.2.0 to before 5.2.5; 6.0.0 to before 6.0.15.1.5, 5.2.5, 6.0.1Patch availableCNA
  • security-advisories Vendornextcloud Affected 5.0.0 to before 5.1.5; 5.2.0 to before 5.2.5; 6.0.0 to before 6.0.1 Fixed in 5.1.5, 5.2.5, 6.0.1 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:nextcloud:sso_\&_saml_authentication:*:*:*:*:*:*:*:*5.0.0 to before 5.1.5; 5.2.0 to before 5.2.5Vulnerablenextcloud
cpe:2.3:a:nextcloud:sso_\&_saml_authentication:6.0.0:*:*:*:*:*:*:*6.0.0Vulnerablenextcloud
  • cpe:2.3:a:nextcloud:sso_\&_saml_authentication:*:*:*:*:*:*:*:* Versions 5.0.0 to before 5.1.5; 5.2.0 to before 5.2.5 Vulnerable ·nextcloud
  • cpe:2.3:a:nextcloud:sso_\&_saml_authentication:6.0.0:*:*:*:*:*:*:* Versions 6.0.0 Vulnerable ·nextcloud

Remediation

  • Fix · CNA security-advisories (nextcloud) Fixed in 5.1.5, 5.2.5, 6.0.1

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-22400

References

Sources