Read the docs
TI-2024-15403 Aliases CVE-2024-23298GHSA-f4j7-jf79-wp46

Apple Xcode: An app may bypass Gatekeeper checks

Priority LOW 25Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

A logic issue was addressed with improved state management. This issue is fixed in Xcode 15.3. An app may bypass Gatekeeper checks.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00521 44th percentileScored 2026-11-07
Fix Fixed Xcode (Apple): 15.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AppleXcodebefore 15.315.3Patch availableCNA
  • Xcode VendorApple Affected before 15.3 Fixed in 15.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apple:xcode:*:*:*:*:*:*:*:*before 15.3VulnerableApple
  • cpe:2.3:a:apple:xcode:*:*:*:*:*:*:*:* Versions before 15.3 Vulnerable ·Apple

Remediation

  • Fix · CNA Xcode (Apple) Fixed in 15.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-23298
  2. 2026-10-03 Alias added: GHSA-f4j7-jf79-wp46

References

  • TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-30709 Git allows arbitrary code execution through broken config quoting KEVCVSS 3.1HIGH 8.1
  • TI-2004-02557 distcc 2.x, as used in XCode 1.5 and others, when not configured to restrict access to… CVSS 2.0HIGH 9.3
  • TI-2014-07619 Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x… CVSS 3.1CRITICAL 9.8
  • TI-2021-04400 malicious repositories can execute remote code while cloning CVSS 3.1HIGH 8.0
  • TI-2016-00666 The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to… CVSS 3.1HIGH 7.5
See all 99 →

Sources