Cross-site scripting in FusionPBX
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
FusionPBX prior to 5.1.0 contains a cross-site scripting vulnerability. If this vulnerability is exploited by a remote authenticated attacker with an administrative privilege, an arbitrary script may be executed on the web browser of the user who is logging in to the product.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00458 39th percentileScored 2026-11-07
Fix Fixed FusionPBX (FusionPBX): 5.1.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA FusionPBX (FusionPBX) Fixed in 5.1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23387
- 2026-10-03 Alias added: GHSA-4xm5-v879-59g7
References
More Fusionpbx vulnerabilities
- TI-2019-08525 app/operator_panel/exec.php in the Operator Panel module in FusionPBX 4.4.3 suffers from… CVSS 3.1HIGH 8.8
- TI-2021-19348 An issue was discovered in FusionPBX before 4.5.30. CVSS 3.1HIGH 8.8
- TI-2019-11215 FusionPBX 4.4.8 allows an attacker to execute arbitrary system commands by submitting a… CVSS 3.0HIGH 8.8
- TI-2022-15865 FusionPBX 5.0.1 was discovered to contain a command injection vulnerability via /fax/fax_send.php. CVSS 3.1CRITICAL 9.8
- TI-2022-10881 Fusionpbx v4.4 and below contains a command injection vulnerability via the download email logs function. CVSS 3.1CRITICAL 9.8
- TI-2019-12649 app/call_centers/cmd.php in the Call Center Queue Module in FusionPBX up to 4.5.7 suffers… CVSS 3.1HIGH 8.8
Sources
- CVE-2024-23387 · CVE Program
- CVE-2024-23387 · NVD
- FIRST EPSS
- GHSA-4xm5-v879-59g7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences