SQL injection in Apache Fineract
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Fineract.This issue affects Apache Fineract: <1.8.5. Users are recommended to upgrade to version 1.8.5 or 1.9.0, which fix the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Apache Fineract — cwiki.apache.org/confluence/display/FINERACT/Apache+Finerac…
3 records Highest priority Priority MEDIUM 3 MEDIUM
Other records, highest priority first
- TI-2024-15578 SQL injection in Apache FineractPriority MEDIUM 45
- TI-2024-15577 Improper privilege management in Apache FineractPriority MEDIUM 42
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23539
- 2026-10-03 Alias added: GHSA-p2vw-f9rr-2m2r
References
More Apache Fineract vulnerabilities
- TI-2022-21954 Apache Fineract allowed an authenticated user to perform remote code execution due to path traversal CVSS 3.1HIGH 8.8
- TI-2026-82963 SQL injection in Apache Fineract Search API CVSS 3.1CRITICAL 9.8
- TI-2018-08455 SQL injection in Apache Fineract CVSS 3.0CRITICAL 9.8
- TI-2018-08454 SQL injection in Apache Fineract CVSS 3.0CRITICAL 9.8
- TI-2025-35952 Apache Fineract: Server Key not masked CVSS 3.1CRITICAL 9.1
- TI-2018-01195 SQL injection in Apache Fineract CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-23539 · CVE Program
- CVE-2024-23539 · NVD
- FIRST EPSS
- GHSA-p2vw-f9rr-2m2r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences